What have you found for these years?


downgrade rubygems

I don't know if it is bundler too dirty or rubygems changed
too radically or fixed a bug or introduced a bug. Anyway,
I get this error running rubygems 1.7.2 and bundler 1.0.11:
source index not created from disk
I would suspect bundler first, but anyway... since rubygems
1.6.2 works fine, so without digging into it, just downgrade
rubygems, that's a lot easier.

Run this:
gem install rubygems-update -v '1.6.2'
update_rubygems --version='1.6.2'
You can't switch rubygems version in Ruby 1.9+, since it's
integrated into the core. Downgrade is the only way to get
around this. As for Ruby 1.8, I think it is possible to put this
on the top of the program to workaround this instead:
gem 'rubygems-update', '1.6.2'
require 'rubygems'
So you don't have to really downgrade rubygems in 1.8.

0 retries:

Post a Comment

Note: Only a member of this blog may post a comment.

All texts are licensed under CC Attribution 3.0