What have you found for these years?

2010-09-16

bundler as version conflict resolver

updated 21:33
ok, I've added ~/.config/Gemfile and read and eval it in
common Gemfile if it exists. This solve the local Gemfile
problem, partially.
path = File.expand_path('~/.config/Gemfile') eval(File.read(path)) if File.exist?(path)
Yes, ruby config file rocks. The same as unicorn and rainbows.

-

Old rails needs rack 1.0.1, while usually I'll have rack 1.2+
installed on my computer. And rails would falsely report that
I didn't install rails for can't activate rack 1.0.1 since rack
1.2.1 has already been activated. We can see this error after
hacking the section about LoadError in boot.rb.

How to resolve this? Even after applying bundler in rails can't
solve this, because calling `unicorn_rails` has already activated
rack 1.2.1, then bundler would complain the same error.

So, this would work:

> bundle exec (which unicorn_rails)

Pretty cool. The down side is that you'll need to specify
unicorn in Gemfile with default group. The next question is,
can I have local Gemfile? Then the world would be perfect.

0 retries:

Post a Comment

All texts are licensed under CC Attribution 3.0