What have you found for these years?

2008-12-09

別升級 datamapper 到 0.9.8...

踩到一堆地雷,一堆莫名其秒的問題,timestamps 導致 validation 不過,
collection.size 居然回傳 nil @@ pagify 好幾個 test case 也掛了。

勉強 patch 了 dm-timestamps, 現在 pagify 出現一堆莫名其妙的問題...
再勉強用 to_a 混過去,但怪怪的地方還是很多 @@

只好在 pagify/data_mapper 前加上:

gem 'extlib', '<=0.9.8'
gem 'dm-core', '<=0.9.7'
gem 'dm-aggregates', '<=0.9.7'

強迫指定用舊版 orz 看來其他東西要整個 revert 回 0.9.7...
extlib 也不能用 0.9.9 啊,因為 dm-core 0.9.7 用到的東西被移掉了
整個就囧..............

看來還是得乖乖用 rails stack 一段時間 :s

==
有遭到報應的感覺...
Dan 又說要調整內部結構,這這很不穩定啊...
datamapper 是在 0.9.x 沒錯,但這叫 merb 如何是好 @_@

0 retries:

Post a Comment

All texts are licensed under CC Attribution 3.0